Назначение программы

 Top Next

Программа Обновление предназначена для синхронизации настроечной информации, находящейся в метаданных (dat-файлах). Программа, в частности, позволяет обновить различные модули пакета без потери настроек, созданных пользователем.

Программа работает со следующими частями инструмента ERP-системы "КОМПАС":

• мастер таблиц;
• мастер печатных форм;
• мастер экранных форм;
• менеджер ролей;
• мастер табличных форм;
• менеджер типов таблиц;
• администратор меню;
• эталонный массив общих мест;
• базовый массив общих мест;
• мастер отчетов;
• мастер запросов;
• мастер бизнес-процедур;
• мастер подготовительных действий;
• мастер заключительных действий;
• мастер настроек рабочего места;
• мастер списка функций ППТР;
• мастер списка действий ППТР;
• отражение документов;
• таблица транслятора;
• мастер монопольных операций;
• мастер объектов блокировки;
• мастер настроек блокировок.

Программа обеспечивает:

·сравнение информации, хранимой в dat-файлах с указанием различающихся объектов и свойств, , а также объектов, отсутствующих в одном из dat-файлов;

·добавление объектов из одного dat-файла в другой;

·замещение объектов или свойств аналогичными из другого dat-файла;

·обновление объекта путем замены различающихся свойств и добавления новых объектов;

·дополнение объекта путем добавления всех новых объектов, входящих в выбранный объект;

·при обновлении метаданных версии 11.85 до версии 12.86 - автоматическое разделение метаданных на метаданные клиентского слоя (описания объектов, измененные пользователем) и стандартные метаданные (описания объектов стандартной версии) и сохранение измененных описаний объектов метаданных в dat-файлы с текущим приоритетом;

·формирование протокола различий (по всем объектам сравниваемых файлов или по одному выделенному в данный момент объекту);

·ведение протокола операций обновления;

·автоматические операции по администрированию таблиц базы данных (проверка наличия, создание, изменение структуры, упаковка, переиндексация);

·администрирование базы данных (настройка псевдонимов базы данных, с которыми будут проводиться массовые операции);

·режим показа только новых и различающихся объектов.


Конфигурация

 Top Previous Next

Конфигурация предназначена для настройки программы обновления.

На закладке Общие настройки предоставляется возможность:

·ведения протокола обновления. По умолчанию протокол не ведется;

·установить режим отображения в мастере табличных форм (Tfman) кнопок, наследуемых от мастера типов таблиц (Tbltypes), т.е. одинаковых для всех табличных форм, созданных по таблицам одного типа. По умолчанию такие кнопки при сравнении метаданных табличных форм отображаются.

Здесь же можно настроить использование внешней программы для сравнения текстов:

·указать путь к исполняемому файлу программы;

·задать параметры для внешней программы;

·указать путь к папке для хранения временных файлов.


Выбор dat-файлов и параметров процедуры сравнения

Выбор сравниваемых dat-файлов и параметров процедуры сравнения

 Top Previous Next

В этой форме производится настройка обновления объектов метаданных: указываются сами объекты – файл с описанием объектов, из которого будут заимствоваться изменения (новая версия) и файл, в который эти изменения будут перенесены (обновляемая версия). Также в этой форме уточняются настройки проведения сравнения и обновления файлов метаданных.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

При выборе файлов всегда руководствуйтесь правилом:

В верхней строке – всегда указывается файл, ОТКУДА будут заимствоваться изменения.

В нижней строке – файл, в который (КУДА) эти изменения будут переноситься.

Если Вы производите обновление версии, использующей многослойную структуру хранения метаданных (12.86), в верхней строке выбирается dat-файл (*.dat), в нижней – файл конфигурации (*.cfg).

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

В форме можно сделать следующие настройки:

·Предусмотрена возможность изменения пути и имени dat-файла. Это можно сделать двумя способами:

- в строке ввода Путь к dat-файлу щелкнуть по кнопке [image] и в диалоге выбора найти и открыть нужный файл;
- набрать с клавиатуры путь и имя dat-файла.

При выходе из формы (нажатии кнопки ОК) проверяется наличие на диске указанных dat-файлов и при их отсутствии выдает соответствующее сообщение, предлагая ввести путь и имя dat-файла или отказаться от запуска соответствующего мастера.

·При обновлении dat-файла меню версии 11.85 до версии 12.86 необходимо также указать пусть к dat-файлу USERACCS.DAT, в котором хранятся права доступа пользователей ко всем пунктам меню всех установленных модулей;

·Тип файла обновляемой версии:

·Если выбран dat-файл, то производится сравнение и обновление dat-файлов;

·Если выбран cfg-файл, то производится сравнение описаний объектов из конкретного dat-файла и описаний, которые используются при работе модуля, из разных однотипных dat-файлов. Пути к этим dat-файлам хранятся в файле <имя модуля>.cfg. Эта возможность может быть использована только для метаданных, хранящихся в разных слоях (начиная с версии 12.86). Здесь же надо указать тип dat-файлов – Мастер, выбрав его наименование из раскрывающегося списка. Как правило, имя мастера устанавливается автоматически. Выбрать имя мастера из списка может потребоваться только при обновлении запросов (queries, quercomm, quertran и т.п.).

·Текущий приоритет – в этом поле при обновлении версии 12.86 указывается приоритет dat-файла, в который будет производиться сохранение описаний объектов метаданных, отличных от стандартных;

·Флажок Cравнивать dat-файлы без учета СУБД. Этот флажок используется только для мастера таблиц. Если флажок установлен, при сравнении dat-файлов с описаниями таблиц не учитываются различия следующих свойств:

- CУБД;

- cоздавать таблицу запросом;

- cоздавать индексы при открытии таблицы;

- символы “dbo.” в начале имени таблицы”.

·Флажок Показывать только различающиеся описания. В зависимости от установки флажка процедура сравнения отображает все или только новые и различающиеся объекты.

·Флажок Выбирать необходимые объекты из списка. Если флажок не задан, осуществляется сравнение всех объектов из dat-файлов. Если флажок установлен, на экран выводится форма выбора объектов для сравнения. Список объектов для выбора формируется в зависимости от положения переключателя в группе Формирование списка: либо из dat-файла новой версии, либо из dat-файла обновляемой.

·Флажок Создать новый dat-файл. Если флажок задан, осуществляется создание нового dat-файла с заданным размером блока и копирование в этот файл всей информации из существующего файла. Использовать эту возможность нужно в следующих случаях:

·когда размер dat-файла приближается к 2048K. В этом случае нужно задать размер блока для нового файла - 64 байт;

·когда размер dat-файла приближается к 4096K. В этом случае нужно задать размер блока для нового файла - 128 байт;

·когда размер dat-файла приближается к 8192K. В этом случае нужно задать размер блока для нового файла - 256 байт.

После того, как новый файл будет создан, его нужно использовать вместо старого файла.


Выбор параметров процедуры сравнения для мастеров обновления таблиц ППТР

 Top Previous Next

Для запуска процедуры сравнения таблиц необходимо указать псевдонимы BDE для таблицы новой версии и обновляемой версии.

В зависимости от установки флажка Показывать только различающиеся описания процедура сравнения отображает все или только новые и различающиеся объекты.


Выбор объектов для сравнения

Top Previous Next

Для запуска процедуры сравнения нужно отметить все объекты, которые Вы хотите сравнивать, и нажать на кнопку Начать сравнение.

При нажатии на кнопку Пометить все все объекты будут помечены.

При нажатии на кнопку Очистить все все установленные пометки будут сняты.


Форма обновления

 Top Previous

Визуально форму обновления можно разделить на следующие части:

·панель новой версии – версии, из которой будут заимствоваться изменения (слева);

·панель обновляемой версии – версии, в которую будут переноситься изменения (справа);

·панель настройки сравнения и обновления (посередине);

·панель управления формой (снизу).

Панели новой версии и обновляемой версии

На каждой из панелей расположены (сверху вниз):

- путь к dat-файлу и номер версии (если она есть);
- дерево объектов и свойств;
- принадлежность текущего (выделенного в дереве) объекта;
- значение объекта или свойства.

В дереве объектов и свойств располагается:

·для новой версии: иерархически упорядоченное содержимое выбранного dat-файла;

·Для обновляемой версии: иерархически упорядоченное содержимое выбранного dat-файла или нескольких однотипных dat-файлов, хранящихся в разных слоях (начиная с версии 12.86) если для определения путей выбран cfg-файл).

При перемещении указателя по одному из деревьев, в другом положение указателя устанавливается на узел, аналогичный выбранному. Узлы, значения которых различаются, помечены значком [image] . Узлы, аналогов которым нет в противоположном дереве, помечены значком [image] . Для перемещения по дереву до следующего / предыдущего отличающегося видимого узла предназначены клавиши Shift + [image] и Shift + [image] . Для перемещения по дереву до следующего / предыдущего отличающегося узла (в том числе и невидимого в данный момент) предназначены клавиши Ctrl + [image] и Ctrl + [image] . При выделении одного из узлов в элементах редактирования, расположенных ниже, показываются принадлежность узла объекту (объектам) и значение узла.

Панель сравнения и обновления

На панели расположены:

-кнопка Добавить - служит для добавления новых объектов из dat-файла новой версии в dat-файл обновляемой версии;

-кнопка Заменить - для замены объекта или свойства обновляемой версии на объект или свойство новой версии;

-кнопка Обновить - для обновления объекта обновляемой версии с помощью объекта новой версии;

-кнопка Дополнить - для добавления всех новых объектов из новой версии, входящих в выбранный объект;

-кнопка Удалить - для удаления объекта обновляемой версии (только тех объектов, которых нет в новой версии).

-индикаторы, показывающие общее количество, количество новых объектов верхнего уровня в обоих деревьях, а также число различных объектов верхнего уровня.

В зависимости от статуса и местоположения выделенного узла (свойство или объект; новый, различающийся или одинаковый; уровень в дереве, узел – родитель) разрешается доступ к тем или иным кнопкам. Вызов вышеописанных функций, выполняемый кнопками, может быть произведен через контекстные меню деревьев и с помощью горячих клавиш.

Панель управления формой

На панели управления формой обновления расположены следующие кнопки:

-Протокол – для выдачи протокола обновления (в данной версии реализован частично);

-Различия все – для выдачи протокола различий по всем объектам сравниваемых файлов;

-Различия - для выдачи протокола различий по тому объекту, который в данный момент выделен;

-Скрыть – для удаления из деревьев одинаковых объектов. После этого будут показаны только новые и различающиеся объекты;

-Выход - завершение процесса обновления


Хранение путей к dat-файлам

 Top

Все пути к dat-файлам модуля хранятся в файлах конфигурации, имеющих расширение DB.

Каждый файл конфигурации содержит пути к dat-файлам, которые используются при работе модуля и которые хранятся в одном слое. Таким образом, при работе одного модуля могут использоваться несколько файлов конфигурации (по количеству используемых слоев). Количество файлов конфигурации может быть произвольным, но все они должны быть в одном формате: либо DB, либо INI.

Местонахождение файлов конфигурации хранится в файле <имя_модуля>.CFG. В этом файле указываются только пути к файлам конфигурации.

См.также:

Многослойная структура хранения метаданных.

Приоритеты метаданных.


Многослойная структура хранения метаданных

 Top

Начиная с версии 12.86, в ERP-системе "КОМПАС" используется многослойная структура хранения метаданных, которая обеспечивает проведение гибких настроек функциональных возможностей системы на различных уровнях.

Базовая функциональность хранится в ядре метаданных. Метаданные ядра и стандартной функциональности системы не могут быть удалены, а метаданные ядра не могут быть изменены. Специфическая функциональность создается и хранится в слоях клиентских настроек, дополняющих ядро и стандартную функциональность. Когда пользователи модифицируют функциональность, изменения сохраняются в том из слоев клиентских настроек, который указан в качестве текущего. В этом же слое сохраняются новые объекты, описывающие функциональность пользователя системы и отсутствующие в слоях поставки.

Многослойная структура хранения метаданных позволяет при работе приложения использовать несколько однотипных dat-файлов (например, файлов с описаниями таблиц).

Рассмотрим в общих чертах принципы хранения и использования объектов метаданных в многослойной структуре на примере dat-файла Tblman.dat.

В качестве объектов метаданных в данном случае выступают таблицы, описание которых хранится в файлах .._ Tblman.dat.

В исходном стандартном (входящим в стандартную поставку) файле TBLMAN.DAT присутствует описание 4-х таблиц (на рисунке – слой 0).

После передачи Клиенту этим Клиентом самостоятельно произведены настройки, в результате которых изменилось описание таблицы 1 (Т.1) и добавилось новое описание таблицы 5 (Т.5). Эти клиентские настройки сохранены уже в другом слое – слое 50. При этом стандартные описания таблиц (слой 0) не претерпели никаких изменений.

При запуске программы считывание описаний объектов метаданных (в данном случае – таблиц) будет производиться следующим образом:

• В самом "верхнем" слое разыскивается файл .._ TBLMAN.DAT. В данном случае – это файл USER_TBLMAN.DAT слоя 50. Из этого файла считываются описания имеющихся в нем объектов;

• Производится поиск файла .._ TBLMAN.DAT в следующем слое, расположенном "ниже". В нашем примере это файл TBLMAN.DAT слоя 0. Из этого слоя считываются описания имеющихся объектов, кроме тех, которые уже были считаны.

В этом примере описания таблиц Т.1 и Т.5 считаны из слоя 50 – эти описания были модифицированы или созданы Клиентом самостоятельно.

Описания таблиц Т.2, Т.3 и Т.4 считаны из слоя 0 – слоя стандартной поставки, описание этих таблиц не изменялось

Хранение стандартных метаданных (ядра и стандартной функциональности) в местах (слоях), расположенных отдельно от настроек Клиентов, позволяет защитить эти данные от несанкционированного их изменения и обеспечить стабильную работоспособность системы. Наличие этих файлов в неизменном виде позволяет быстро отказаться от сделанных клиентских настроек и вернуться к стандартной версии программы.

Таким образом, с использованием многослойной структуры хранения метаданных, dat-файл версии поставки остается в неизменном виде, все объекты, которые когда-либо изменялись клиентом и отличаются от присутствующих в стандартной версии, размещаются в другом dat-файле. При работе системы считывается информация одновременно из двух dat-файлов с описаниями однородных объектов:

См.также:

Хранение путей к dat-файлам


Приоритеты метаданных

 Top

Принадлежность метаданных (dat-файла) какому-либо слою определяется приоритетом этого dat-файла.

Условно слои метаданных посредством использования приоритетов делятся на группы. Деление определяется следующими настройками:

·ReadOnlyPriority – приоритет с правами "только чтение", определяет слои метаданных, изменение которых запрещено, так же, как и создавать метаданные с таким же именем. Возможен просмотр;

·CurrentPriority – текущий приоритет, определяет слой, в котором сохраняются все изменения метаданных, редактирование которых разрешено, и вновь созданные метаданные.

Внимание!

Поставка версии 12.86 предусматривает наличие двух слоев хранения метаданных:

1.Слой, в котором хранятся стандартные описания объектов метаданных. В этом слое размещаются dat-файлы версии поставки. Описания метаданных в этом слое не могут быть изменены клиентами. Этот слой определяется как ReadOnlyPriority и имеет приоритет 0.

2.Слой, в котором сохраняются описания объектов метаданных, которые когда-либо изменялись клиентом и отличаются от стандартных. Этот слой определяется как CurrentPriority и имеет приоритет 50.

См.также:

Многослойная структура хранения метаданных.

Хранение путей к dat-файлам